Página 1 de 1

Letras al arrancar el QL

Publicado: 15 Jun 2019 18:38
por Miguel angel rojo
Bueno, parece que tanta caña al QL no le ha debido ir bien, y me pasa una cosa curiosa, sin el interface de disco al arrancar se me pone la pantalla toda verde.
Y se queda tal que así.
Y con el TDI me aparece unas letras extrañas y me arranca normalmente pero me da que no detecta la CF.
He de hacer algunas pruebas más
Podría ser la rom?

Re: Letras al arrancar el QL

Publicado: 15 Jun 2019 20:17
por jltursan
Parece que tienes una ROM Minerva instalada :-)

Esos números parece que indican un error relacionado con la RAM. Si siempre son los mismos, probablemente sea un integrado de la RAM; si varían, hay un 245 al lado de la ROM que suele provocar estos fallos cuando casca.

Re: Letras al arrancar el QL

Publicado: 15 Jun 2019 20:40
por ron
Había una página con los códigos de boot de QL, creo que era de Josë_Leandro, pero no la doy encontrada.
Venían los códigos y los significados, por lo que dice jl tiene pinta de ser un integrado de ram que no anda fino.

¿Qué tienes conectado al QL cuando lo enciendes ?

Re: Letras al arrancar el QL

Publicado: 15 Jun 2019 21:49
por Zerover
Minerva muestra esos códigos cuando hay algún fallo en el checkeo de RAM. Indican los valores de pruebas y la dirección

Re: Letras al arrancar el QL

Publicado: 15 Jun 2019 21:54
por Miguel angel rojo
Tengo conectado al arrancar el interface Tetroid, hace lo de los números y luego arranca el Minerva.
Si es la ram, se sabrá si están calientes, no?

Y donde se puede conseguir eso? Ah, y vienen soldados en placa no?

Re: Letras al arrancar el QL

Publicado: 16 Jun 2019 20:26
por jltursan
Cualquiera de estos te podría valer:

HM4864-2
HM4864P-2
HM4864AP-2
µPD4164-2
M5K416NS-20
MK4564N-20
MSM3764-20
M3764-20RS
MN4164P-20
LH2164-Z1
TMM4164AP-20
TMS4164-20NL

Son integrados de DRAM 64Kx1. Versiones más rápidas también serían compatibles, acabarían en - 15 en lugar de - 20 y todas ellas son fácilmente encontrables en eBay.

Habría que desoldar claro y lo del calor no tiene porque funcionar, a veces el chip está caliente (lo cual es una gran ayuda) y otras frío. También a veces funciona el "piggyback" (montar una encima de otra) de un integrado en buen estado sobre cada uno de los soldados siempre que no estén calientes. Si cambian los números es probable que ese integrado esté mal.

Re: Letras al arrancar el QL

Publicado: 18 Jun 2019 10:49
por Miguel angel rojo
Muchas gracias, lo de desoldar, uff.....
Puedo ocasionar la de chernovil en la placa,
aparte que tampoco tengo soldador, bueno veré como me apaño.