Manual de uso del interface MEGAFLASH (CAP. 2)

Avatar de Usuario
wilco2009
Mensajes: 1684
Registrado: 07 Ene 2013 16:48
Ubicación: Valencia
Agradecido : 59 veces
Agradecimiento recibido: 111 veces

Re: Manual de uso del interface MEGAFLASH (CAP. 2)

Mensajepor wilco2009 » 03 Ene 2014 21:58

Último mensaje de la página anterior:

Acabo de comprobar que simplemente metiendolo solo un poco, sin hacerlo hasta el final, aunque meta lo mismo de los dos lados también funciona siempre.
Se confirma que es del conector, pero aun tengo que entender cual es el problema.
"Nada viaja a mayor velocidad que luz con la posible excepción de las malas noticias las cuales obedecen a sus propias leyes."

Douglas Adams. Guía de autoestopista galáctico.

flopping
Mensajes: 2137
Registrado: 26 Jun 2011 17:50
Agradecido : 1 vez
Agradecimiento recibido: 2 veces

Re: Manual de uso del interface MEGAFLASH (CAP. 2)

Mensajepor flopping » 03 Ene 2014 22:33

Wilco2009, que estaba pensando que quizá el problema es que el conector es demasiado profundo y al insertarlo hasta el tope, deja de hacer buen contacto, quizá deberíamos de ponerle un tope en el fondo, por ejemplo, coge un palillo redondo o medio palillo y metelo en el fondo del conector, de esta forma, hará tope y quizá los contactos sean mejores, ¿Entiendes lo que quiero decir?.

Avatar de Usuario
wilco2009
Mensajes: 1684
Registrado: 07 Ene 2013 16:48
Ubicación: Valencia
Agradecido : 59 veces
Agradecimiento recibido: 111 veces

Re: Manual de uso del interface MEGAFLASH (CAP. 2)

Mensajepor wilco2009 » 03 Ene 2014 22:47

Le he puesto una esponjilla dura de 1cm de grosor pegada en la parte delantera de la caja, y ha sido mano de santo.
Creo que es la solución. :-]
"Nada viaja a mayor velocidad que luz con la posible excepción de las malas noticias las cuales obedecen a sus propias leyes."

Douglas Adams. Guía de autoestopista galáctico.

Avatar de Usuario
ron
Mensajes: 17668
Registrado: 28 Oct 2010 14:20
Ubicación: retrocrypta
Agradecido : 758 veces
Agradecimiento recibido: 803 veces

Re: Manual de uso del interface MEGAFLASH (CAP. 2)

Mensajepor ron » 03 Ene 2014 22:56

Iba a comentar que con una ampliación de RAM que tengo de 16KB para ZX81 me sucedía otro tanto de lo mismo y la solución pasa por ponerle un tope como dice flopping. Bien sea a nivel de conector o de carcasa, pero de momento no he podido aún mecanizar la mía.

Espero que ese sea todo el problema, al menos me alegra saber que he podido ayudar a detectarlo. Saludos !!!

Avatar de Usuario
wilco2009
Mensajes: 1684
Registrado: 07 Ene 2013 16:48
Ubicación: Valencia
Agradecido : 59 veces
Agradecimiento recibido: 111 veces

Re: Manual de uso del interface MEGAFLASH (CAP. 2)

Mensajepor wilco2009 » 03 Ene 2014 23:04

De todas formas puedes hacer la prueba poniendo la esponjilla directamente sobre la placa a ver si así te funciona.
"Nada viaja a mayor velocidad que luz con la posible excepción de las malas noticias las cuales obedecen a sus propias leyes."

Douglas Adams. Guía de autoestopista galáctico.

Avatar de Usuario
ron
Mensajes: 17668
Registrado: 28 Oct 2010 14:20
Ubicación: retrocrypta
Agradecido : 758 veces
Agradecimiento recibido: 803 veces

Re: Manual de uso del interface MEGAFLASH (CAP. 2)

Mensajepor ron » 04 Ene 2014 00:10

wilco2009 escribió:De todas formas puedes hacer la prueba poniendo la esponjilla directamente sobre la placa a ver si así te funciona.


Más que una esponjilla, un pedazito de plastico o de madera... ya os iré contando.

Avatar de Usuario
wilco2009
Mensajes: 1684
Registrado: 07 Ene 2013 16:48
Ubicación: Valencia
Agradecido : 59 veces
Agradecimiento recibido: 111 veces

Re: Manual de uso del interface MEGAFLASH (CAP. 2)

Mensajepor wilco2009 » 04 Ene 2014 00:32

Sí, algo duro.
Yo he utilizado una esponjilla muy densa y dura que para el caso es lo mismo.
"Nada viaja a mayor velocidad que luz con la posible excepción de las malas noticias las cuales obedecen a sus propias leyes."

Douglas Adams. Guía de autoestopista galáctico.

Avatar de Usuario
wilco2009
Mensajes: 1684
Registrado: 07 Ene 2013 16:48
Ubicación: Valencia
Agradecido : 59 veces
Agradecimiento recibido: 111 veces

Re: Manual de uso del interface MEGAFLASH (CAP. 2)

Mensajepor wilco2009 » 05 Ene 2014 01:08

Corrijo medidas de la plaquita dura a colocar en la parte superior del conector:

- Si está instalada la caja debe ser de 4 ó 5 mm
- En el caso de no disponer de caja debe ser de 1cm aprox. tal y como había dicho anteriormente.

A mi no me ha vuelto a fallar desde que lo he puesto.
La he pegado con un trozo de cinta adhesiva de doble cara.
Añado fotos para que lo veáis:

Imagen

Imagen
"Nada viaja a mayor velocidad que luz con la posible excepción de las malas noticias las cuales obedecen a sus propias leyes."

Douglas Adams. Guía de autoestopista galáctico.

Avatar de Usuario
ron
Mensajes: 17668
Registrado: 28 Oct 2010 14:20
Ubicación: retrocrypta
Agradecido : 758 veces
Agradecimiento recibido: 803 veces

Re: Manual de uso del interface MEGAFLASH (CAP. 2)

Mensajepor ron » 07 Ene 2014 12:03

He vuelto a montar el CPC con la placa blanquecina, con su drive de 3 1/2" y ha sido enchufar el megaflash ( aún sin mecanizar ) la mitad y HA FUNCIONADO AL PRIMER ENCENDIDO. Asunto resuelto por mi parte.

Ahora si que sería bueno hacer una recopilación de las ROMS más interesantes que le podemos meter y dejar un post nuevo con todo ese material.

Saludos

Avatar de Usuario
wilco2009
Mensajes: 1684
Registrado: 07 Ene 2013 16:48
Ubicación: Valencia
Agradecido : 59 veces
Agradecimiento recibido: 111 veces

Re: Manual de uso del interface MEGAFLASH (CAP. 2)

Mensajepor wilco2009 » 07 Ene 2014 12:06

Pues parece que se confirma que el problema es que hay que enchufarlo solo hasta la mitad.
Curiosos conectores.

Por lo menos hemos localizado el problema que estaba dando tantos dolores de cabeza. Espero que a los demás también se les solucione de esta manera.
"Nada viaja a mayor velocidad que luz con la posible excepción de las malas noticias las cuales obedecen a sus propias leyes."

Douglas Adams. Guía de autoestopista galáctico.

Avatar de Usuario
jrodriguezv
Mensajes: 736
Registrado: 05 Jul 2012 10:32
Agradecido : 8 veces
Agradecimiento recibido: 7 veces
Contactar:

Re: Manual de uso del interface MEGAFLASH (CAP. 2)

Mensajepor jrodriguezv » 07 Ene 2014 12:43

Yo ayer estuve probando el mio, pero no he sido capaz de hacerlo funcionar, ni siquiera introduciendo el conector hasta el 50%. Hice pruebas con los dos programas para hacer la inicialización y copias de ROM a algunos de los slots, pero nada. Al final acabé un poco desesperado, porque no se que he hecho que ahora no arranca el CPC con el interfaz conectado y lo dejé para otro día :(

El hilo también me ha valido para saber por qué narices estaba teniendo tantos problemas con la unidad de disco externa, resulta que también tengo que meter el conector hasta la mitad.

Avatar de Usuario
wilco2009
Mensajes: 1684
Registrado: 07 Ene 2013 16:48
Ubicación: Valencia
Agradecido : 59 veces
Agradecimiento recibido: 111 veces

Re: Manual de uso del interface MEGAFLASH (CAP. 2)

Mensajepor wilco2009 » 07 Ene 2014 12:46

jrodriguezv escribió:Yo ayer estuve probando el mio, pero no he sido capaz de hacerlo funcionar, ni siquiera introduciendo el conector hasta el 50%. Hice pruebas con los dos programas para hacer la inicialización y copias de ROM a algunos de los slots, pero nada. Al final acabé un poco desesperado, porque no se que he hecho que ahora no arranca el CPC con el interfaz conectado y lo dejé para otro día :(

El hilo también me ha valido para saber por qué narices estaba teniendo tantos problemas con la unidad de disco externa, resulta que también tengo que meter el conector hasta la mitad.


Pregunta tonta. ¿Los jumpers de la ROM0 y 7 los tienes en posición ON?
"Nada viaja a mayor velocidad que luz con la posible excepción de las malas noticias las cuales obedecen a sus propias leyes."

Douglas Adams. Guía de autoestopista galáctico.

Avatar de Usuario
jrodriguezv
Mensajes: 736
Registrado: 05 Jul 2012 10:32
Agradecido : 8 veces
Agradecimiento recibido: 7 veces
Contactar:

Re: Manual de uso del interface MEGAFLASH (CAP. 2)

Mensajepor jrodriguezv » 07 Ene 2014 12:50

No, los tengo a la derecha.

Cuando arranco algunas veces me aparece un mensaje de "pres play then any key..." otras veces el número 65535 en pantalla (esto también le ha pasado a ron) y ya no he vuelto a ser capaz de arrancar con el interfaz conectado. Como acabé un poco saturado lo dejé.

Avatar de Usuario
wilco2009
Mensajes: 1684
Registrado: 07 Ene 2013 16:48
Ubicación: Valencia
Agradecido : 59 veces
Agradecimiento recibido: 111 veces

Re: Manual de uso del interface MEGAFLASH (CAP. 2)

Mensajepor wilco2009 » 07 Ene 2014 12:57

Precisamente.
Para poder arrancar con la memoria en blanco hay que tener los jumpes en ON (a la izquierda), para que esté activa la ROM0 interna del CPC. Si los tienes en OFF no encontrará el Basic y se colgará en el arranque.
"Nada viaja a mayor velocidad que luz con la posible excepción de las malas noticias las cuales obedecen a sus propias leyes."

Douglas Adams. Guía de autoestopista galáctico.

Avatar de Usuario
jrodriguezv
Mensajes: 736
Registrado: 05 Jul 2012 10:32
Agradecido : 8 veces
Agradecimiento recibido: 7 veces
Contactar:

Re: Manual de uso del interface MEGAFLASH (CAP. 2)

Mensajepor jrodriguezv » 07 Ene 2014 13:13

Cuando llegue a casa lo vuelvo a probar, pero tal y cómo lo tenía en un principio era capaz de arrancar.

Gracias por tu ayuda wilco.

Avatar de Usuario
jrodriguezv
Mensajes: 736
Registrado: 05 Jul 2012 10:32
Agradecido : 8 veces
Agradecimiento recibido: 7 veces
Contactar:

Re: Manual de uso del interface MEGAFLASH (CAP. 2)

Mensajepor jrodriguezv » 07 Ene 2014 18:39

Te confirmo que con los dos a on ahora no me arranca.

Avatar de Usuario
jrodriguezv
Mensajes: 736
Registrado: 05 Jul 2012 10:32
Agradecido : 8 veces
Agradecimiento recibido: 7 veces
Contactar:

Re: Manual de uso del interface MEGAFLASH (CAP. 2)

Mensajepor jrodriguezv » 07 Ene 2014 18:59

Yo creo que me he cargado el mio porque haga lo que haga ahora hace un bucle todo el rato. Como cuando tengo los dos jumpers en off, pero mas rápido.


Volver a “Amstrad”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado