ZX81. Cargando programas en un ZX81

Avatar de Usuario
ron
Mensajes: 17743
Registrado: 28 Oct 2010 14:20
Ubicación: retrocrypta
Agradecido : 801 veces
Agradecimiento recibido: 860 veces

ZX81. Cargando programas en un ZX81

Mensajepor ron » 19 Oct 2012 14:08

Hilo origen : viewtopic.php?p=100043496#p100043496

Imagen

El zx81 tiene dos serias limitaciones para usar las cargas de alta velocidad.
Su escasa memoria RAM y una velocidad de carga standard muy lenta. (300 bps)

Proyecto OTLA Adaptación ZX81 (Hi-speed loading for zx81)


http://microhobby.speccy.cz/zx81/

Imagen

Imagen

He estado haciendo pruebas y creo que he pasado mi propio record intentando hacer que un bicho cargue software.

En este caso y al igual que muchos micros, a través de audio, pues es la única interfaz disponible de serie, así que mucha paciencia y al tema.

Dos intentos de suicidio, y una frustración alarmante me tuvieron durante un par de horas en tensión y es lo de siempre, el modulador de video del ZX81 así como su triste interfaz de carga son elementos que pueden poner a más de uno de los nervios.

Así que intentaré ayudar con mi experiencia, al final todo OK

Primero de todo, la fuente de audio, he usado casi todos los programas que hay para convertir ficheros .P y .T81 con resultados negativos.

Servirá la salida de auriculares de los altavoces del PC, la salida de Audio, un MP3 o un reproductor de WAV. El volumen al 75 - 80 %. Mono.

Al final lo único que me ha cargado/funcionado son los WAV que descargué de aquí. http://www.bobs-stuff.co.uk/zx81.html

Y a las pruebas me remito. EL ZX81 durante la carga perdía totalmente la sintonía y la TV se quedaba sin señal, al menos durante el tiempo que tarda en cargar. Una vez cargado y como por arte de magia el video vuelve con el programa cargado. También me ha servido para probar que la ampliación de RAM a 16 KB también funciona perfectamente.

Imagen

Imagen

Imagen

Imagen

Imagen

Imagen

Imagen

Usando tapeutils.jar

Código: Seleccionar todo

javaw -Xmx750M -jar tapeutils.jar

java -jar tapeutils.jar -s "3D Monster Maze.wav" -p 3dMonsterMaze.p


El WAV generado es de 32 segundos, carga a la primera.

Imagen

Imagen

Todo requeteprobado. PRUEBA SUPERADA

Imagen

Imagen

Imagen

Imagen

jose_leandro
Mensajes: 306
Registrado: 23 Ene 2012 20:20
Agradecimiento recibido: 25 veces

Re: ZX81. Cargando programas en un ZX81

Mensajepor jose_leandro » 19 Oct 2012 14:33

Hola Ron

Es normal que el zx81 pierda la señal de video cuando estas cargando cintas. Resulta que la ULA del zx81 tiene multiplexada las 2 señales sobre la misma patilla.

Así que cuando hay una cosa, no puede haber otra.

Pero no te preocupes, a mi me chocó también la primera vez y ¡eso que me lo sabía! :-P -laughing

Saludos

José Leandro

Anaxagoras

Re: ZX81. Cargando programas en un ZX81

Mensajepor Anaxagoras » 19 Oct 2012 15:15

jose_leandro escribió:Hola Ron

Es normal que el zx81 pierda la señal de video cuando estas cargando cintas. Resulta que la ULA del zx81 tiene multiplexada las 2 señales sobre la misma patilla.

Así que cuando hay una cosa, no puede haber otra.

Pero no te preocupes, a mi me chocó también la primera vez y ¡eso que me lo sabía! :-P -laughing

Saludos

José Leandro


Hola.

De hecho yo pensaba que estaba diseñado así a propósito para dar feedback de que estaba cargando -unknw

jltursan
Mensajes: 2136
Registrado: 20 Sep 2011 13:59
Agradecido : 91 veces
Agradecimiento recibido: 216 veces

Re: ZX81. Cargando programas en un ZX81

Mensajepor jltursan » 19 Oct 2012 18:07

Mira tú por donde que ese tapeutils.jar era lo que andaba buscando desde hacía un tiempo para poder alimentar un TK85 que he ido tuneando desde hace un tiempo. Como dices, la mayor parte de los conversores, no acaban de funcionar bien...:(

dancresp
Mensajes: 5166
Registrado: 13 Nov 2010 02:08
Agradecido : 69 veces
Agradecimiento recibido: 134 veces

Re: ZX81. Cargando programas en un ZX81

Mensajepor dancresp » 30 Oct 2012 15:29

El "tapeutils.jar" funciona perfectamente.

Y lo de perder la sintonía al hacer LOAD es normal ya que el ZX-81 entra en modo FAST y no refresca la imagen.

Decir que cuando aparecen las rayas negras horizontales unas 20 y pico veces está acabando de cargar (modo 16KB).

Avatar de Usuario
ron
Mensajes: 17743
Registrado: 28 Oct 2010 14:20
Ubicación: retrocrypta
Agradecido : 801 veces
Agradecimiento recibido: 860 veces

Re: ZX81. Cargando programas en un ZX81

Mensajepor ron » 08 Ene 2013 21:54

Para las utilidades , las descargas de los jar y otras cosas: Aquí ---> http://www.zx81stuff.org.uk/zx81/tapeutils/

tapeutils.rar
(187.86 KiB) Descargado 359 veces

Avatar de Usuario
ron
Mensajes: 17743
Registrado: 28 Oct 2010 14:20
Ubicación: retrocrypta
Agradecido : 801 veces
Agradecimiento recibido: 860 veces

Re: ZX81. Cargando programas en un ZX81

Mensajepor ron » 06 Ene 2014 22:22

Añado el WinTape ZX de Pete Todd.

viewtopic.php?f=99&t=200030614

download/file.php?id=20005006

Imagen
wintape.jpg
wintape.jpg (43.23 KiB) Visto 362 veces


Volver a “Instrucciones Carga Software”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado