Basura en la pantalla

Avatar de Usuario
minter
Mensajes: 1748
Registrado: 22 Jul 2014 18:51
Agradecido : 1043 veces
Agradecimiento recibido: 463 veces

Basura en la pantalla

Mensajepor minter » 13 Ago 2014 18:05

Buenas!

Gracias a un compañero por otro foro, conseguí una fuente para C64 para poder darle calor al 6510!
¿Cual fue mi sorpresa? Que no le da la gana de arrancar!
Bueno, ya lo sabía de hace tiempo, pero no recordaba ni como era del todo el arranque, ni tenía fotos de la pantalla.
Es un revision B bastante limpito. Ha estado en su cajita durante 25 años -shock
Y ahora se levanta con resaca.
¿Alguna pista de donde empezar a buscar antes de ponerme a arrancar componente como una loca?
Apongo las afotos!

Por cierto, a vosotros se os pudre el plastico de la carcasa, que parece como si se desintegrasa... y de polvo son y al polvo se convertiran...??? -shock MIEDO!
Imagen

jltursan
Mensajes: 2135
Registrado: 20 Sep 2011 13:59
Agradecido : 91 veces
Agradecimiento recibido: 216 veces

Re: Basura en la pantalla

Mensajepor jltursan » 13 Ago 2014 18:19

Si tuvieses un cartucho estaría genial para probar si funciona con él. ..
En cualquier caso, abrelo y todo lo que esté en zócalo, sácalo y vuélvelo a meter bien apretado, especialmente U1 y U2, las CIAs 6526 (que probablemente si que estarán en zócalo :-)).

Avatar de Usuario
Kaboom3D
Mensajes: 79
Registrado: 03 Abr 2014 19:22
Ubicación: Barcelona
Agradecido : 1 vez
Agradecimiento recibido: 1 vez

Re: Basura en la pantalla

Mensajepor Kaboom3D » 13 Ago 2014 20:58

Precisamente estoy liado con la reparación de un C64. Ayer me llegó una placa que quería para componentes y que sacaba la pantalla en negro, pero después de hacer varias veces seguidas "on-off-on-off-on-off-on", me saca la misma pantalla que a tí. He sustituido el VIC-II y nada, aparece o en negro o con esa pantalla. Ni idea de lo que puede ser, pero como tengo la otra placa que sí saca video, creo que con esta no me voy a liar demasiado.

Y si, mi panera se deshace igual que la tuya... la mitad de las "torretas" de tornillos ya no existen y el plástico cruje que da miedito :(

Avatar de Usuario
minter
Mensajes: 1748
Registrado: 22 Jul 2014 18:51
Agradecido : 1043 veces
Agradecimiento recibido: 463 veces

Re: Basura en la pantalla

Mensajepor minter » 14 Ago 2014 01:38

Bueno, después de sacar los integrados que tenían zócalo y pegarles un chorreo de arena, ataque con ácido y limpieza con Don Limpio...
Sigue como estaba.
Sólo tengo zócalos en los integrados grandes, los pequeños están todos soldados a la placa y no tengo el desoldador a mano.
La ROM pienso yo que funciona, ya que en la pantalla se ven cargados los caracteres, que aunque sean aleatoria mente, se visualizan. (osea, que algo se carga en memoria)
El de video... pues video saca, aunque sea mierdoso.
La CPU... bueno, sin ella vería todo negro, no?

Tengo que comprobar las tensiones en la placa, no vaya a ser que me falle alguna alimentación y por eso flipe.
Las temperaturas de los integrados, después de 5 minutos están normal, no parecen que se pongan a "tope con la COPE."
Y comprobaré los condensadores, no vaya a ser que alguno se haya ido de baretas. -drinks
Aunque la temperatura ambiente donde estoy ahora mismo es de 17 grados, así que refrigerado está de narices. Puto y loco verano en la costa verde!!! -angry2

mcleod_ideafix
Mensajes: 925
Registrado: 13 Ene 2012 09:45

Re: Basura en la pantalla

Mensajepor mcleod_ideafix » 14 Ago 2014 02:39

Sospechoso principal en estos casos: la PLA.
Cada vez que se implementa un sistema clásico en FPGA, Dios mata a un purista.

Avatar de Usuario
ron
Mensajes: 17743
Registrado: 28 Oct 2010 14:20
Ubicación: retrocrypta
Agradecido : 801 veces
Agradecimiento recibido: 860 veces

Re: Basura en la pantalla

Mensajepor ron » 14 Ago 2014 10:07

Holas, estoy mas perdido que perry mason en la Mancha, y desde el "mancontro_con_internet" sigo los posts de la casa ;-)

Este es a mi humilde opinion otro de los fallos " NPI" que a veces nos encontramos con las paneras, y es que puede ser cualquier cosa y podemos estar dando vueltas que acabaremos mareados y se repiten los sintomas que describe Minter con una similitud asombrosa.

Esta conversacion la tuvimos entre varios con Xgipe en la RetroVilobiWiki del Penedes y despues de deducir se termino por concluir que si no era la PLA ni la RAM pudiera ser un multiplexor, aunque al final nada de lo dicho era el causante de la averia.

Y es cierto que las paneras terminan autosuicidandose y convirtiendose en cachitos que se transforman en polvo estelar, sobre todo el plastico de la carcasa exterior y solo se me ocurre decir que tienen mal envejecer.

A ver si das con ello, para estos casos y dar con la averia es necesario en ocasiones tirar de algo mas que un polimetro, ya casi es hasta necesario tirar de osciloscopio y con los medios apropiados y un poco de ayuda suele recuperarse casi todo, asi que paciencia y ganas, no queda otra.

Perdonad los typos, escribo desde movil.

Avatar de Usuario
Gatuso
Mensajes: 146
Registrado: 06 Ene 2014 11:55
Agradecido : 1 vez
Agradecimiento recibido: 15 veces

Re: Basura en la pantalla

Mensajepor Gatuso » 14 Ago 2014 10:53

Ten a mano la pagina de Ray Carlsen, en especial su texto sobre diagnóstico de averias por si puede serte útil. Hay también un directorio con pantallazos de los fallos mas comunes que puede ser un buen punto de partida para la investigación.

Imagen

retrolab
Mensajes: 360
Registrado: 10 May 2014 18:06
Agradecido : 1 vez
Agradecimiento recibido: 5 veces

Re: Basura en la pantalla

Mensajepor retrolab » 14 Ago 2014 11:00

A mi me paso algo patecido con uno de nuestros c64 y era la 2114 ram de video que estaba mal. Si tienes un 2114 puefes nontarlo encima solo para hacer la prueba y a ver si hay suerte.

Avatar de Usuario
minter
Mensajes: 1748
Registrado: 22 Jul 2014 18:51
Agradecido : 1043 veces
Agradecimiento recibido: 463 veces

Re: Basura en la pantalla

Mensajepor minter » 14 Ago 2014 13:22

Memoria? No me acuerdo!
He hecho inventario de lo que tengo, y no tengo memoria de repuesto.
A ver si puedo localizar alguna en la tienda de chuches.
Un oscilo no tengo, pero tengo que hacerme con un carchucho para comprobar si arranca con el puesto.
El problema es que tampoco tengo un equipo para ir sustituyendo y descartar componentes.
Con el esquema voy a ponerme a comprobar tensiones a ver que patilla se queda colgada. Es un metodo patatero pero es lo unico que puedo hacer por el momento.
Lo curioso es que esta averia surgio sola. El equipo se embalo funcinando cuando me llego el amiga, y despues de años, sucedio esto, por eso sospecho de los condensadores, que tampoco son eternos.
Ire informando! -grin

mcleod_ideafix
Mensajes: 925
Registrado: 13 Ene 2012 09:45

Re: Basura en la pantalla

Mensajepor mcleod_ideafix » 15 Ago 2014 22:09

retrolab escribió:A mi me paso algo patecido con uno de nuestros c64 y era la 2114 ram de video que estaba mal. Si tienes un 2114 puefes nontarlo encima solo para hacer la prueba y a ver si hay suerte.

La memoria 2114 es la RAM de color. Si estuviera mal, lo que verías serían caracteres correctos (el mensaje de bienvenida del C64 BASIC, por ejemplo) pero con los colores equivocados.
Aquí lo que se ve es caracteres equivocados, lo que significa que la RAM no está guardando bien la información, o no se la están dando bien. Si fuera un chip de RAM defectuoso se vería algún tipo de patrón (un carácter que se repite más que otro), pero aquí no veo eso, por eso me inclino, como primer sospechoso, por la PLA, que además casca con más frecuencia incluso que la RAM.
Cada vez que se implementa un sistema clásico en FPGA, Dios mata a un purista.

Avatar de Usuario
minter
Mensajes: 1748
Registrado: 22 Jul 2014 18:51
Agradecido : 1043 veces
Agradecimiento recibido: 463 veces

Re: Basura en la pantalla

Mensajepor minter » 16 Ago 2014 01:10

Buenas!
Bueno, eso que dices que hay un carácter que se repite mas que otro, si que suele pasar.
El 50% de las ocasiones que lo enciendo, el carácter predominante es la @ (arroba), y se repite prácticamente por toda la pantalla.
Si puedo, cuelgo mas tarde una foto, con ese patrón en el que se ve mas arrobas que la canción de TamTam Go - Atrapados en la red. -grin

PD: Para el que siga este hilo y el del CommodoreMania, que no se haga la picha un lío. Jeff y Minter somos la misma persona. Pero el Jeff de allí no es el Jeff de aquí, sino Minter. Quiero decir, en commodoremania soy Jeff y aquí soy Minter. No somos dos personas con el mismo fallo en el ordenador. Sino la misma, con un follón de tres pares de pelotas. Simplemente amplié la consulta por si mi fallo era coñocido. -hypo
De todos modos, gracias por las ideas que me estáis aportando. Aunque me van a costar un poco llevar a la practica sin los medios adecuados de los que dispongo.

mcleod_ideafix
Mensajes: 925
Registrado: 13 Ene 2012 09:45

Re: Basura en la pantalla

Mensajepor mcleod_ideafix » 16 Ago 2014 03:25

Minter escribió:Buenas!
Bueno, eso que dices que hay un carácter que se repite mas que otro, si que suele pasar.
El 50% de las ocasiones que lo enciendo, el carácter predominante es la @ (arroba), y se repite prácticamente por toda la pantalla.

Bueno.... no es de extrañar: el código de la arroba en el C64 es el 0. No recuerdo la secuencia de inicialización del Kernal, pero si como imagino, pone la memoria a 0 como parte de su chequeo, es normal que en la pantalla aparezca aunque sea por un momento la arroba llenando la pantalla.
No se puede descartar nada, y menos sin tener algún tipo de cartucho ROM de testeo, pero sigo pensando que el principal sospechoso es la PLA. ¿Puedes abrir la máquina y comprobar si el chip marcado como U17 se calienta mucho mucho?
Cada vez que se implementa un sistema clásico en FPGA, Dios mata a un purista.

Avatar de Usuario
minter
Mensajes: 1748
Registrado: 22 Jul 2014 18:51
Agradecido : 1043 veces
Agradecimiento recibido: 463 veces

Re: Basura en la pantalla

Mensajepor minter » 17 Ago 2014 01:37

Se calienta el que más el U18, el SID.
Tendría que comprobarlo con él desenchufado, pero ya no me da tiempo. Se acabaron mis vacaciones, así que el Commodore ha vuelto al armario.
Retomaremos el post cuando vuelva a disponer del equipo.

GRACIAS A TODOS!
-thumbup

Avatar de Usuario
minter
Mensajes: 1748
Registrado: 22 Jul 2014 18:51
Agradecido : 1043 veces
Agradecimiento recibido: 463 veces

Re: Basura en la pantalla

Mensajepor minter » 12 May 2015 22:25

Gatuso escribió:Ten a mano la pagina de Ray Carlsen, en especial su texto sobre diagnóstico de averias por si puede serte útil. Hay también un directorio con pantallazos de los fallos mas comunes que puede ser un buen punto de partida para la investigación.

Imagen


Como no localizaba mi JBC para desoldar la placa, me hice con un desoldador de 9 pavetes en una tienda de Madrid.

Desoldador de 9 pavos.jpg
Calienta y chupa por 9 pavos.
Desoldador de 9 pavos.jpg (62.84 KiB) Visto 644 veces


La PLA, ya la había remplazado por el MOD de la EPROM (que funciona perfectamente con ella, sin artefactos raros en pantalla).

Entonces, me puse a desoldar lo que me quedaba, la memoria y los bufers.

Proceso:
PIM!!
Placa C64 Sin memorias.jpg
Desoldada la placa.
Placa C64 Sin memorias.jpg (87.73 KiB) Visto 644 veces


PAM!
Placa ya con zocalos.jpg
Con zócalos de los caros. Grrrrr.
Placa ya con zocalos.jpg (92.55 KiB) Visto 644 veces


y PUM!!!
placa con memorias.jpg
Placa poblada de piojos negros.
placa con memorias.jpg (83.4 KiB) Visto 644 veces


Enciendo el ordenador.... Y nada!!!

Lo vuelvo a abrir, y veo que había dejado la PLA y el SID fuera. -banghead

Y Gatuso se lleva el Gatuso al agua!!!!! -drinks

Les presento al culpable!!!!!

DRAM C64 Averiada.jpg
Taaa Chaaan!!!
DRAM C64 Averiada.jpg (38.26 KiB) Visto 644 veces


Después de haber dejado las memorias con zócalo, me puse a probar por nibbles.
Cambio 4... y no pasa nada. Cambio los otros 4 y el ordenador enciende.Restituyo los 4 primeros, y sigue bien, sin basura...
Y después de un par de combinaciones más, apareció el culpable!!!! El U21, una memoria.

Lo monto de nuevo... lo enciendo... Y FUNCIONA!!!! -thumbup

Pantalla de saludo.jpg
C64 levanta la patita!
Pantalla de saludo.jpg (57.43 KiB) Visto 644 veces


Es resto de los componentes estaban bien. Así que los repuse en su sitio y el resto, para futuros apaños.

Y para finalizar, desempolvo la unidad de cassete... y despues de unas cuantas pruebas limpiando los contactos, comprobando el estado de las gomas y dando vueltas al azimut... llegamos a este punto:

https://www.youtube.com/watch?v=G49RYWujLDM

Esto es cacharreo con canas!!! -507

Avatar de Usuario
ron
Mensajes: 17743
Registrado: 28 Oct 2010 14:20
Ubicación: retrocrypta
Agradecido : 801 veces
Agradecimiento recibido: 860 veces

Re: Basura en la pantalla

Mensajepor ron » 12 May 2015 22:35

Después de haber dejado las memorias con zócalo, me puse a probar por nibbles.
Cambio 4... y no pasa nada. Cambio los otros 4 y el ordenador enciende.Restituyo los 4 primeros, y sigue bien, sin basura...
Y después de un par de combinaciones más, apareció el culpable!!!! El U21, una memoria.


-drinks -rofl -cocbm1 -thumbup -11 -mfr_lol -lighten -good -taunt -clapping -Laie_73 -tease -winner_first_h4h


Volver a “Software C64”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado