Y otro C64 malito

Avatar de Usuario
duca750
Mensajes: 1565
Registrado: 19 May 2015 10:52
Ubicación: Olivenza (Badajoz)
Agradecido : 414 veces
Agradecimiento recibido: 120 veces

Y otro C64 malito

Mensajepor duca750 » 26 Jul 2019 22:42

Bueno, como no escarmiento, he comprado otro C64 con peor aspecto con la esperanza de entre uno y otro sacar los dos adelante o al menos 1.

Este otro siempre da pantalla negra, salvo a veces que da toda la imagen azul, o toda verde, o toda gris, o toda rosa, o todo blanco, pero la mayoría de veces negro. Y una de 100 veces más o menos así...

Creo que este pinta mucho peor...

PhotoPictureResizer_190726_224119129-750x1000.jpg
PhotoPictureResizer_190726_224119129-750x1000.jpg (38.23 KiB) Visto 589 veces


Y otra así.

PhotoPictureResizer_190726_224307942-750x1000.jpg
PhotoPictureResizer_190726_224307942-750x1000.jpg (61.65 KiB) Visto 588 veces


Ahm cuando sale blanca, se oye como un ruido de interferencia, con los demás colores creo que no. Al final voy a tener que conseguir un cartucho de diagnóstico o aceptar el préstamo del compañero.

Fotos de la PCB y de un transistor con pinta rara...

PhotoPictureResizer_190726_230321924_crop_903x857.jpg
PhotoPictureResizer_190726_230321924_crop_903x857.jpg (63.84 KiB) Visto 578 veces
PhotoPictureResizer_190726_230222651-750x1000.jpg
PhotoPictureResizer_190726_230222651-750x1000.jpg (93.87 KiB) Visto 578 veces
PhotoPictureResizer_190726_230337374-1000x750.jpg
PhotoPictureResizer_190726_230337374-1000x750.jpg (98.52 KiB) Visto 578 veces
-4mstr4d CPC464(7),472 Y 6128 (2) -sp3zy 16K&48K GOMAS,+2,+2A/2B +3 -cocbm1 64 Y -coam1** -0r1c 1 (2ud) y ATMOS** -m3s3x CANON V20, SPECTRAVIDEO 728,TOSHIBA HX10, PHILIPS VG8020,2 NMS 8250+GOTEK -j4tar1 STFM 800XL -3nt3r 64-ACORN ELECTRON -codrg1 32

Avatar de Usuario
minter
Mensajes: 2897
Registrado: 22 Jul 2014 18:51
Agradecido : 3132 veces
Agradecimiento recibido: 1313 veces

Re: Y otro C64 malito

Mensajepor minter » 26 Jul 2019 22:47

Apuesto un gusarapu a la PLA!!
Me ariesgo a un VIC en buen estado. Mire usted. XD
Los dos C64, que revisiones son?
Fotos de las placas, una en cada hilo.
Pero ya! -507

Avatar de Usuario
duca750
Mensajes: 1565
Registrado: 19 May 2015 10:52
Ubicación: Olivenza (Badajoz)
Agradecido : 414 veces
Agradecimiento recibido: 120 veces

Re: Y otro C64 malito

Mensajepor duca750 » 26 Jul 2019 23:06

minter escribió:Apuesto un gusarapu a la PLA!!
Me ariesgo a un VIC en buen estado. Mire usted. XD
Los dos C64, que revisiones son?
Fotos de las placas, una en cada hilo.
Pero ya! -507

Editado y con fotos de ambas PCB. Parecen iguales, pero veo que algún componente no lo es.

En el otro hilo también he puesto fotos. Gracias!!!
-4mstr4d CPC464(7),472 Y 6128 (2) -sp3zy 16K&48K GOMAS,+2,+2A/2B +3 -cocbm1 64 Y -coam1** -0r1c 1 (2ud) y ATMOS** -m3s3x CANON V20, SPECTRAVIDEO 728,TOSHIBA HX10, PHILIPS VG8020,2 NMS 8250+GOTEK -j4tar1 STFM 800XL -3nt3r 64-ACORN ELECTRON -codrg1 32

Avatar de Usuario
minter
Mensajes: 2897
Registrado: 22 Jul 2014 18:51
Agradecido : 3132 veces
Agradecimiento recibido: 1313 veces

Re: Y otro C64 malito

Mensajepor minter » 26 Jul 2019 23:14

En esta placa, antes de ponerte a soltar integrados, comprueba que las tensiones son correctas.
Estoy de cenorrio, pero como me aburro... :)
Bueno, pues coje el.esquema y revisa tensiones.

Avatar de Usuario
duca750
Mensajes: 1565
Registrado: 19 May 2015 10:52
Ubicación: Olivenza (Badajoz)
Agradecido : 414 veces
Agradecimiento recibido: 120 veces

Re: Y otro C64 malito

Mensajepor duca750 » 26 Jul 2019 23:22

Pues a mí lo retro me encanta pero los cenorriosssss, no tienes perdón jajajaja. Dale caña, mañana busco los esquemas y me pongo a enredar a ver qué avanzo y aver si los entiendo. Gracias y buen provecho.

Comentar que U18 se calienta, pero U17 se pone al rojo vivo en 20 30 segundos...
-4mstr4d CPC464(7),472 Y 6128 (2) -sp3zy 16K&48K GOMAS,+2,+2A/2B +3 -cocbm1 64 Y -coam1** -0r1c 1 (2ud) y ATMOS** -m3s3x CANON V20, SPECTRAVIDEO 728,TOSHIBA HX10, PHILIPS VG8020,2 NMS 8250+GOTEK -j4tar1 STFM 800XL -3nt3r 64-ACORN ELECTRON -codrg1 32

Avatar de Usuario
duca750
Mensajes: 1565
Registrado: 19 May 2015 10:52
Ubicación: Olivenza (Badajoz)
Agradecido : 414 veces
Agradecimiento recibido: 120 veces

Re: Y otro C64 malito

Mensajepor duca750 » 26 Jul 2019 23:23

Duplicado
-4mstr4d CPC464(7),472 Y 6128 (2) -sp3zy 16K&48K GOMAS,+2,+2A/2B +3 -cocbm1 64 Y -coam1** -0r1c 1 (2ud) y ATMOS** -m3s3x CANON V20, SPECTRAVIDEO 728,TOSHIBA HX10, PHILIPS VG8020,2 NMS 8250+GOTEK -j4tar1 STFM 800XL -3nt3r 64-ACORN ELECTRON -codrg1 32

Avatar de Usuario
Hodor
Mensajes: 1192
Registrado: 19 May 2015 10:55
Ubicación: A 900km de Oviedo
Agradecido : 206 veces
Agradecimiento recibido: 245 veces

Re: Y otro C64 malito

Mensajepor Hodor » 26 Jul 2019 23:36

duca750 escribió:Pues a mí lo retro me encanta pero los cenorriosssss, no tienes perdón jajajaja. Dale caña, mañana busco los esquemas y me pongo a enredar a ver qué avanzo y aver si los entiendo. Gracias y buen provecho.

Comentar que U18 se calienta, pero U17 se pone al rojo vivo en 20 30 segundos...


U18 corresponde con el SID y es muy normal que se caliente bastante -te recomiendo ponerle un disipador, por cierto. U17 es la PLA y, aunque también se caliente, no me parece normal que llegue a quemar. Por tanto ahí tienes una pista por donde comenzar a tirar del hilo.

Quickie
Mensajes: 43
Registrado: 01 Nov 2018 17:48
Agradecido : 6 veces
Agradecimiento recibido: 19 veces

Re: Y otro C64 malito

Mensajepor Quickie » 27 Jul 2019 00:22

Mmmm...esas interferencias y esos colores....
El VIC-II no creo que esté mal, no así PLA..
y SID. Prueba a arrancar sin SID, a ver como se comporta.

Por cierto, te llegaron y cambiaste los 74LS258 del otro c64?

Avatar de Usuario
duca750
Mensajes: 1565
Registrado: 19 May 2015 10:52
Ubicación: Olivenza (Badajoz)
Agradecido : 414 veces
Agradecimiento recibido: 120 veces

Re: Y otro C64 malito

Mensajepor duca750 » 27 Jul 2019 01:19

Quickie escribió:Mmmm...esas interferencias y esos colores....
El VIC-II no creo que esté mal, no así PLA..
y SID. Prueba a arrancar sin SID, a ver como se comporta.

Por cierto, te llegaron y cambiaste los 74LS258 del otro c64?

Gracias, seguiré entonces los tutoriales de cómo crear esos componentes, a ver qué hace falta y cómo hacerlo, de echo aún no los he mirado. En fin, cruzaré los dedos al menos para que no sea como dices el vic.me llegaron 74LS257 no eran esos?
-4mstr4d CPC464(7),472 Y 6128 (2) -sp3zy 16K&48K GOMAS,+2,+2A/2B +3 -cocbm1 64 Y -coam1** -0r1c 1 (2ud) y ATMOS** -m3s3x CANON V20, SPECTRAVIDEO 728,TOSHIBA HX10, PHILIPS VG8020,2 NMS 8250+GOTEK -j4tar1 STFM 800XL -3nt3r 64-ACORN ELECTRON -codrg1 32

Avatar de Usuario
duca750
Mensajes: 1565
Registrado: 19 May 2015 10:52
Ubicación: Olivenza (Badajoz)
Agradecido : 414 veces
Agradecimiento recibido: 120 veces

Re: Y otro C64 malito

Mensajepor duca750 » 27 Jul 2019 01:36

Hodor escribió:
duca750 escribió:Pues a mí lo retro me encanta pero los cenorriosssss, no tienes perdón jajajaja. Dale caña, mañana busco los esquemas y me pongo a enredar a ver qué avanzo y aver si los entiendo. Gracias y buen provecho.

Comentar que U18 se calienta, pero U17 se pone al rojo vivo en 20 30 segundos...


U18 corresponde con el SID y es muy normal que se caliente bastante -te recomiendo ponerle un disipador, por cierto. U17 es la PLA y, aunque también se caliente, no me parece normal que llegue a quemar. Por tanto ahí tienes una pista por donde comenzar a tirar del hilo.


Si te soy sincero en C64 estoy verdisimo, revisaré a ver si los componentes son iguales y se puede ir intercambiando algo. Gracias.
-4mstr4d CPC464(7),472 Y 6128 (2) -sp3zy 16K&48K GOMAS,+2,+2A/2B +3 -cocbm1 64 Y -coam1** -0r1c 1 (2ud) y ATMOS** -m3s3x CANON V20, SPECTRAVIDEO 728,TOSHIBA HX10, PHILIPS VG8020,2 NMS 8250+GOTEK -j4tar1 STFM 800XL -3nt3r 64-ACORN ELECTRON -codrg1 32

jjsaenz1969
Mensajes: 632
Registrado: 21 Oct 2016 15:45
Agradecido : 178 veces
Agradecimiento recibido: 216 veces

Re: Y otro C64 malito

Mensajepor jjsaenz1969 » 27 Jul 2019 08:00

El SID para las pruebas lo puedes quitar, el C64 puede arrancar sin el.

Quickie
Mensajes: 43
Registrado: 01 Nov 2018 17:48
Agradecido : 6 veces
Agradecimiento recibido: 19 veces

Re: Y otro C64 malito

Mensajepor Quickie » 27 Jul 2019 10:15

duca750 escribió:
Hodor escribió:
duca750 escribió:Pues a mí lo retro me encanta pero los cenorriosssss, no tienes perdón jajajaja. Dale caña, mañana busco los esquemas y me pongo a enredar a ver qué avanzo y aver si los entiendo. Gracias y buen provecho.

Comentar que U18 se calienta, pero U17 se pone al rojo vivo en 20 30 segundos...


U18 corresponde con el SID y es muy normal que se caliente bastante -te recomiendo ponerle un disipador, por cierto. U17 es la PLA y, aunque también se caliente, no me parece normal que llegue a quemar. Por tanto ahí tienes una pista por donde comenzar a tirar del hilo.


Si te soy sincero en C64 estoy verdisimo, revisaré a ver si los componentes son iguales y se puede ir intercambiando algo. Gracias.



Hola,

Perdona, si, los multiplexores eran 74LS257, solo quería saber si hubo suerte con el otro y te da ánimos a liarte a reparar éste :)

Antes de pensar en sustituir nada, prueba a arrancar con lo básico. PLA y VIC-II son necesarios, pero el SID no.
Según la página que te comenté de The Pictorial C64 Fault Guide han habido casos de c64 con el SID estropeado que generaban un patrón parecido (mira esa onda de la izquierda...).
El caso de la PLA es mas peliagudo. Si tienes otro C64 con una PLA funcional, tómala prestada temporalmente y así descartas culpables.

Una vez consigas arrancar o bien Dead Test Cart o mejor aun, la pantalla de inicio de Basic ya puedes buscar reemplazo de ese componente.

marcos64
Mensajes: 426
Registrado: 08 Nov 2018 10:31
Agradecido : 76 veces
Agradecimiento recibido: 143 veces

Re: Y otro C64 malito

Mensajepor marcos64 » 27 Jul 2019 10:39

No utilices los U17, U18... para indicar los chips. Usa sus codigos 6581, 6526... porque en diferentes revisiones de placas corresponden a diferentes chips y eso puede (y lo hace) dar lugar a malentendidos.

Ese U17, si a los 20 o 30 segundos no puedes dejar el dedo encima presionando, ahi tienes al culpable al 99% (existe la posibilidad de que algo mas este mal).

Comprueba tensiones, y si todo esta bien, cambialo con el de la otra placa.

Y como han dicho saca el SID, puede dar pantalla negra si esta mal y si esta bien no es necesario arriesgarlo.

Las CIAs 6526 las puedes intercambiar.
http://marcos64.orgfree.com/
Actualizacion 22/4/2018: Actualizada Load'N'Run numero 5 con nuevos TAPs y PRGs.

Avatar de Usuario
duca750
Mensajes: 1565
Registrado: 19 May 2015 10:52
Ubicación: Olivenza (Badajoz)
Agradecido : 414 veces
Agradecimiento recibido: 120 veces

Re: Y otro C64 malito

Mensajepor duca750 » 27 Jul 2019 18:01

marcos64 escribió:No utilices los U17, U18... para indicar los chips. Usa sus codigos 6581, 6526... porque en diferentes revisiones de placas corresponden a diferentes chips y eso puede (y lo hace) dar lugar a malentendidos.

Ese U17, si a los 20 o 30 segundos no puedes dejar el dedo encima presionando, ahi tienes al culpable al 99% (existe la posibilidad de que algo mas este mal).

Comprueba tensiones, y si todo esta bien, cambialo con el de la otra placa.

Y como han dicho saca el SID, puede dar pantalla negra si esta mal y si esta bien no es necesario arriesgarlo.

Las CIAs 6526 las puedes intercambiar.

Comprendo, no estoy muy familiarizado con C64, con el SID quitado el resultado es similar.

Las cías 6526 van en zócalo en este, pero directas en PCB en el otro. Voy a revisar las tensiones con la información que me habéis adjuntado. Gracias
-4mstr4d CPC464(7),472 Y 6128 (2) -sp3zy 16K&48K GOMAS,+2,+2A/2B +3 -cocbm1 64 Y -coam1** -0r1c 1 (2ud) y ATMOS** -m3s3x CANON V20, SPECTRAVIDEO 728,TOSHIBA HX10, PHILIPS VG8020,2 NMS 8250+GOTEK -j4tar1 STFM 800XL -3nt3r 64-ACORN ELECTRON -codrg1 32

Avatar de Usuario
duca750
Mensajes: 1565
Registrado: 19 May 2015 10:52
Ubicación: Olivenza (Badajoz)
Agradecido : 414 veces
Agradecimiento recibido: 120 veces

Re: Y otro C64 malito

Mensajepor duca750 » 27 Jul 2019 18:02

Quickie escribió:
duca750 escribió:
Hodor escribió:
U18 corresponde con el SID y es muy normal que se caliente bastante -te recomiendo ponerle un disipador, por cierto. U17 es la PLA y, aunque también se caliente, no me parece normal que llegue a quemar. Por tanto ahí tienes una pista por donde comenzar a tirar del hilo.


Si te soy sincero en C64 estoy verdisimo, revisaré a ver si los componentes son iguales y se puede ir intercambiando algo. Gracias.



Hola,

Perdona, si, los multiplexores eran 74LS257, solo quería saber si hubo suerte con el otro y te da ánimos a liarte a reparar éste :)

Antes de pensar en sustituir nada, prueba a arrancar con lo básico. PLA y VIC-II son necesarios, pero el SID no.
Según la página que te comenté de The Pictorial C64 Fault Guide han habido casos de c64 con el SID estropeado que generaban un patrón parecido (mira esa onda de la izquierda...).
El caso de la PLA es mas peliagudo. Si tienes otro C64 con una PLA funcional, tómala prestada temporalmente y así descartas culpables.

Una vez consigas arrancar o bien Dead Test Cart o mejor aun, la pantalla de inicio de Basic ya puedes buscar reemplazo de ese componente.

Gracias compañero, como comento con el SID quitado es el mismo comportamiento. La PLA en el otro equipo va directa en placa. Voy a revisar tensiones a ver si veo algo más. Gracias.
-4mstr4d CPC464(7),472 Y 6128 (2) -sp3zy 16K&48K GOMAS,+2,+2A/2B +3 -cocbm1 64 Y -coam1** -0r1c 1 (2ud) y ATMOS** -m3s3x CANON V20, SPECTRAVIDEO 728,TOSHIBA HX10, PHILIPS VG8020,2 NMS 8250+GOTEK -j4tar1 STFM 800XL -3nt3r 64-ACORN ELECTRON -codrg1 32


Volver a “Hardware C64”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado