Averia Spectrum 16K Issue 2

radiosity
Mensajes: 8
Registrado: 01 Dic 2016 09:54
Agradecido : 1 vez
Agradecimiento recibido: 1 vez

Averia Spectrum 16K Issue 2

Mensajepor radiosity » 01 Feb 2017 12:40

Hola gente,

Un amigo comun del foro ha rescatado de por ahi un par de placas de spectrum 16/48K. El caso es que una de ellas al final con mucho sudor, consegui echarla para delante y esta funcionando. El problema viene con esta issue 2. Os dejo una captura del sintoma que da en pantalla. Pruebo memorias y sigue igual, probada otra ULA, tensiones de alimentacion OK. La ROM esta bien supongo porque enganchando el dandanator tambien falla. Como no sea el micro ya no se que puede ser.

Imagen

Gracias de antemano.

Avatar de Usuario
dandare
Mensajes: 349
Registrado: 15 Jul 2016 00:38
Ubicación: Madrid, Córdoba, Luanco
Agradecido : 20 veces
Agradecimiento recibido: 88 veces
Contactar:

Re: Averia Spectrum 16K Issue 2

Mensajepor dandare » 01 Feb 2017 13:29

¿hace algo cuando le das al reset?. ¿Has arrancado el test de la Rom? (pulsa el botón izquierdo del dandanator al enchufar el spectrum. El menú del Dandanator no funciona en spectrums de 16k, por lo que podría ser la ROM
_.. ._ _.

radiosity
Mensajes: 8
Registrado: 01 Dic 2016 09:54
Agradecido : 1 vez
Agradecimiento recibido: 1 vez

Re: Averia Spectrum 16K Issue 2

Mensajepor radiosity » 01 Feb 2017 16:01

Probe con otra ROM con identico resultado.

Avatar de Usuario
dandare
Mensajes: 349
Registrado: 15 Jul 2016 00:38
Ubicación: Madrid, Córdoba, Luanco
Agradecido : 20 veces
Agradecimiento recibido: 88 veces
Contactar:

Re: Averia Spectrum 16K Issue 2

Mensajepor dandare » 01 Feb 2017 17:40

radiosity escribió:Probe con otra ROM con identico resultado.


Lo del reset es importante, nos da pistas de si el Z80 tiene pinta de estar vivo o no. En cualquier caso, yo revisaría y/o cambiaría si es posible el IC3 y el IC4 (74LS157).
_.. ._ _.

radiosity
Mensajes: 8
Registrado: 01 Dic 2016 09:54
Agradecido : 1 vez
Agradecimiento recibido: 1 vez

Re: Averia Spectrum 16K Issue 2

Mensajepor radiosity » 02 Feb 2017 08:26

dandare escribió:
radiosity escribió:Probe con otra ROM con identico resultado.


Lo del reset es importante, nos da pistas de si el Z80 tiene pinta de estar vivo o no. En cualquier caso, yo revisaría y/o cambiaría si es posible el IC3 y el IC4 (74LS157).

Pues no es mala esa opcion. Ayer probe memorias nuevas y me sale el mismo patron.

radiosity
Mensajes: 8
Registrado: 01 Dic 2016 09:54
Agradecido : 1 vez
Agradecimiento recibido: 1 vez

Re: Averia Spectrum 16K Issue 2

Mensajepor radiosity » 06 Feb 2017 07:35

Bueno pues la ROM al final con tanta prueba cascó. Pero conseguí reparar el otro sintoma y efectivamente eran los 74157. Una vez cambiados me arranco el dandanator. Eso si el arranque desde la ROM interna no lo hace, sale barras verticales y el test del dandanator me da ROM corrupta o desconocida. El color al final me fallaba por tema de la ULA que no hace bien contacto con el zocalo.

Avatar de Usuario
dandare
Mensajes: 349
Registrado: 15 Jul 2016 00:38
Ubicación: Madrid, Córdoba, Luanco
Agradecido : 20 veces
Agradecimiento recibido: 88 veces
Contactar:

Re: Averia Spectrum 16K Issue 2

Mensajepor dandare » 06 Feb 2017 09:54

Lástima lo de la ROM. Tiene arreglo fácil en cualquier caso.
Me alegro de que esté ya funcionando el equipo. Enhorabuena.
_.. ._ _.


Volver a “Hardware Spectrum”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 2 invitados