Página 1 de 1

Zx Spectrum 128k español problema

Publicado: 03 Jul 2020 13:44
por vito
Buenas, tengo un problemílla con mi recién adquirido 128k español, me he hecho la clavija de 8 pines para sacar imagen por AV conectando en el número 2 la masa y en el 3 la señal y me sale la imagen en blanco y negro, he probado con otro igual de un compañero y lo mismo, me estoy equivocando de pin? o es que hago alguna cosa mal.

Agradecería cualquier ayuda.

Re: Zx Spectrum 128k español problema

Publicado: 03 Jul 2020 13:48
por Taburoto
Los 128k no tienen video en color,para convertir ese señal en color se requiere abrir el ordenador y hacer unos cambios.

Re: Zx Spectrum 128k español problema

Publicado: 03 Jul 2020 14:32
por ron
Puedes hacerte un cable RGB a Scart ( euroconector ) o usar en su defecto una GBS8200 para convertir el RGB a lo que quieras.

Tengo este pdf hace tiempo, a ver si te sirve.


Me parece que ahí viene lo que buscas. Saludos

Re: Zx Spectrum 128k español problema

Publicado: 03 Jul 2020 14:45
por vito
Muchas gracias a los dos, ya tengo información para ver por donde me decanto.

Un saludo.

PD: Espero no ser muy cansino con las preguntas.

Re: Zx Spectrum 128k español problema

Publicado: 03 Jul 2020 14:55
por llopis
Taburoto escribió:Los 128k no tienen video en color,para convertir ese señal en color se requiere abrir el ordenador y hacer unos cambios.

¿Cómo dices?? Si estamos hablando de los 128K normales, sí que tienen vídeo en color por el conector RGB. No es igual que el 128K británico o que los +2, pero no tienes que hacerle nada dentro para sacar vídeo en color.

Aquí tienes mucha información sobre el tema (me suena que es lo mismo que el pdf que puso Ron):
http://www.fruitcake.plus.com/Sinclair/ ... panish.htm

Re: Zx Spectrum 128k español problema

Publicado: 03 Jul 2020 15:10
por vito
Si, lo que dice Taburoto tiene razón o eso creo, si hablamos de la salida AV (no RGB), he estado buscando mas información y he visto que hay una modificación interna mediante un puente y levantando un diodo se soluciona, pero no me quiero meter en estos embrollos de momento.
El caso es que tengo un monitor lcd antiguo de ordenador conexión VGA y me compre un adaptador de av a vga y funciona bien pero en blanco y negro, y no sabia si era culpa del 128 o del aparato conversor.

Re: Zx Spectrum 128k español problema

Publicado: 03 Jul 2020 15:31
por llopis
vito escribió:Si, lo que dice Taburoto tiene razón o eso creo, si hablamos de la salida AV (no RGB), he estado buscando mas información y he visto que hay una modificación interna mediante un puente y levantando un diodo se soluciona, pero no me quiero meter en estos embrollos de momento.
El caso es que tengo un monitor lcd antiguo de ordenador conexión VGA y me compre un adaptador de av a vga y funciona bien pero en blanco y negro, y no sabia si era culpa del 128 o del aparato conversor.

Ah vale, no sabía que la salida AV era diferente de la RGB. Ya me extrañaba a mí :-)

Re: Zx Spectrum 128k español problema

Publicado: 03 Jul 2020 15:38
por Kyp
Según el esquema que hay por internet, al conector RGB va la salida LUMO (es decir, blanco y negro) del chip TEA (pin 7) pasando por un par de transistores. Creo recordar que lo probé en su momento y efectivamente salía en B/N. Cambiando la señal por COVO (pin 6) sale en color (video compuesto), no se por qué hicieron así el diseño.

Yo lo hice levantando el pin central de TR13 y haciendo un puente al pin 6 de TEA
03.jpg
03.jpg (72.04 KiB) Visto 255 veces


El otro cable es porque luego lo llevé al conector RCA del modulador para poder usar el típico cable de video compuesto.

Re: Zx Spectrum 128k español problema

Publicado: 03 Jul 2020 15:52
por vito
Ok Ok.
Esto se pone interesante.
Haber como le meto mano o me compro un "ZX-VGA-JOY"
Gracias Kyp

Re: Zx Spectrum 128k español problema

Publicado: 03 Jul 2020 16:53
por flopping
Sabes que el conector de la señal RGB usa 4 contactos verdad? y según sea esa señal, puede usar hasta cinco, ya que a veces la señal de sincro hay que mandarla también, vamos que el cable que tienes tiene que tener conectados como mínimo 4 pines, ya que si estas usando solo la señal de vídeo compuesto, es normal que solo se vea en blanco y negro con ese convertidor, salu2.

Re: Zx Spectrum 128k español problema

Publicado: 03 Jul 2020 17:25
por vito
flopping escribió:Sabes que el conector de la señal RGB usa 4 contactos verdad? y según sea esa señal, puede usar hasta cinco, ya que a veces la señal de sincro hay que mandarla también, vamos que el cable que tienes tiene que tener conectados como mínimo 4 pines, ya que si estas usando solo la señal de vídeo compuesto, es normal que solo se vea en blanco y negro con ese convertidor, salu2.


Gracias por la información.

Después de todo lo que habéis comentado, tendré que mirar o RGB o el ZX-VGA-JOY.

Unn saludo.