Página 4 de 9

Re: Amiga 1200 black screen y sin actividad de disquetera

Publicado: 30 Mar 2019 20:46
por flopping

Último mensaje de la página anterior:

Resuelda los condensadores reemplazados, eso de que tengas que mover la sonda a lo largo de algunas soldaduras no indica nada bueno, al mover la sonda, haces presión y entonces si se produce el contacto deseado, pero al dejar de hacer presión, se pierde ese contacto, por lo que la soldadura puede estar mal, ten en cuenta que puede parecer que una soldadura está bien, pero realmente no hacer contacto con el pad, lo mejor es que uses algo de Flux que limpia los pads y hace que la soldadura se coja mejor, yo también creo que no debe de haber ningún componente mal, por eso te digo que me inclino más a alguna mala soldadura o pista cortada, por eso te decía que resoldaras con flux todos los condensadores de nuevo, salu2.

Re: Amiga 1200 black screen y sin actividad de disquetera

Publicado: 30 Mar 2019 22:46
por minter
o la punta de la sonda es mala...
O tienes restos de resina en la soldadula, por eso hay que "entrar a matar" la soldadura.
.

Re: Amiga 1200 black screen y sin actividad de disquetera

Publicado: 31 Mar 2019 12:41
por Hodor
A finales de esta semana probablemente me lleguen unos muelles y pivotes para reparar varias teclas que no me funcionan. También he de comprar alcohol isopropílico y limpiar con él la membrana del teclado, así que en cuanto lo tenga todo aprovecharé para quitar la estática con el papel del plata y repasar las soldaduras. Ya os iré contando.

Mil gracias por vuestra ayuda y consejos.

Re: Amiga 1200 black screen y sin actividad de disquetera

Publicado: 03 Abr 2019 20:49
por Hodor
Me temo que volvemos de nuevo a las andadas -banghead .

Resulta que ayer por la noche lo conecté y black screen durante más de veinte minutos. Me da por apagarlo y encenderlo de nuevo, pasan como diez segundos y arranca. Lo tengo una hora probando diversos juegos y demos todo funcionando como la seda.

flopping escribió:Resuelda los condensadores reemplazados, eso de que tengas que mover la sonda a lo largo de algunas soldaduras no indica nada bueno, al mover la sonda, haces presión y entonces si se produce el contacto deseado, pero al dejar de hacer presión, se pierde ese contacto, por lo que la soldadura puede estar mal, ten en cuenta que puede parecer que una soldadura está bien, pero realmente no hacer contacto con el pad, lo mejor es que uses algo de Flux que limpia los pads y hace que la soldadura se coja mejor, yo también creo que no debe de haber ningún componente mal, por eso te digo que me inclino más a alguna mala soldadura o pista cortada, por eso te decía que resoldaras con flux todos los condensadores de nuevo, salu2.


Esta tarde le he pasado el papel de plata a todos los integrados con el ordenador apagado y sin cablear, tal y como me recomendaste. También he resoldado dos condensadores que parecían tener soldaduras frías. Tras retirarlos, limpiar y soldar de nuevo, el multímetro detecta continuidad con mucha mayor facilidad que antes, simplemente tocando suavemente con la sonda en la gota de estaño. Pues bien, arranco el ordenador sin la disquetera y la tarjeta CF....black screen. Lo dejo media hora encendido por si acaso reacciona como ayer por la noche. Nada, ni reacción ni hostias. Apago y vuelvo a encender, nada, black screen -banghead

Es desesperante.

Re: Amiga 1200 black screen y sin actividad de disquetera

Publicado: 03 Abr 2019 23:26
por ron
Hodor, es muy fuerte ! la cosa es que poltergeist o trasgo, yo hablaba con Iker.
En eso que has resoldado tengo la impresión que algo que cuelga de ahí es lo que causa el problema. Ya sea pista o componente. Y sinó tira un poco de arroz en el suelo para que el trasgu se vuelva loco intentando recogerlo y se pire y te funcione de nuevo el 1200.

Re: Amiga 1200 black screen y sin actividad de disquetera

Publicado: 03 Abr 2019 23:47
por minter
ron escribió:Hodor, es muy fuerte ! la cosa es que poltergeist o trasgo, yo hablaba con Iker.
En eso que has resoldado tengo la impresión que algo que cuelga de ahí es lo que causa el problema. Ya sea pista o componente. Y sinó tira un poco de arroz en el suelo para que el trasgu se vuelva loco intentando recogerlo y se pire y te funcione de nuevo el 1200.


Nomeno..
No ye esu, oh!

Ye el Chip Gamusino, faltale uno, guaje!

Gamusinos.jpg
Gamusinos.jpg (139.05 KiB) Visto 678 veces


-grin

Re: Amiga 1200 black screen y sin actividad de disquetera

Publicado: 04 Abr 2019 12:41
por Hodor
Pues no os debe de faltar razón, no. Debe ser que ahora le toca de nuevo dejar de funcionar durante otra temporadita.

En fin, hoy estoy algo más animado. Ayer por la noche me entraron ganas de tirar el ordenador por la ventana.

Re: Amiga 1200 black screen y sin actividad de disquetera

Publicado: 04 Abr 2019 22:58
por flopping
Sigo pensando que es una rotura de pista o falsa soldadura en algun(os) condensador(es).

Re: Amiga 1200 black screen y sin actividad de disquetera

Publicado: 05 Abr 2019 11:03
por Hodor
flopping escribió:Sigo pensando que es una rotura de pista o falsa soldadura en algun(os) condensador(es).


Probablemente, pero falta saber dónde. Y justo aquí se encuentra el problema ya que el ordenador no muestra un patrón fijo de malfuncionamiento. Hace un tiempo, por ejemplo, reparé un Amiga 500 y un Commodore 64. Ambos repetían el tipo de avería continuamente y de forma más o menos predecible. Y en ambos pude ir descartando cosas hasta llegar al causante. Sin embargo, con este ordenador me siento como si estuviese buscando una aguja en un pajar.

Partimos de que tras varios meses comienza a funcionar gracias a un corto accidental. Lo cual en sí mismo parece una tomadura de pelo. Le conecto los RCA de sonido, descarga de estática no sé muy bien por qué, y deja de funcionar de nuevo. Otro corto en esta ocasión no accidental y resucita. Durante unos días arranca sin problema y sin demora ninguna. Le conecto la disquetera y comienza a tocar los cojones. Que si ahora te salto con una black screen y tras diez segundos arranco bien, que si luego son 20 segundos, hoy me despierto de buen humor y arranco inmediatamente...Hasta que un buen día pasa media hora de black screen sin dar señales de vida. Y al día siguiente da igual que pase media hora, una hora o tres, no arranca porque no le sale de las pelotas.

¿Alguien ve algún patrón extraño ahí? Salvo el hecho de que comenzó a demorar el arranque una vez le conecté la disquetera, el resto parece puro capricho. Y para finalizar digamos que cuando funciona lo hace sin mostrar fallo alguno: nada de cuelgues, reseteos o gráficos corruptos. Sonido perfecto y carga normal tanto desde disco duro como desde disquetera. Añadiendo además que la ROM de diagnóstico no ha detectado nada anómalo.

Un saludo.

Re: Amiga 1200 black screen y sin actividad de disquetera

Publicado: 05 Abr 2019 11:22
por carmeloco
¿Tienes ampliación de memoria en el trapdoor? En mi A500 tenía problemas intermitentes, hasta que lo arranqué sin la ampliación de RAM del trapdoor. La solución fue cambiar los condensadores electrolíticos de la ampliación.

Re: Amiga 1200 black screen y sin actividad de disquetera

Publicado: 05 Abr 2019 12:03
por Hodor
carmeloco escribió:¿Tienes ampliación de memoria en el trapdoor? En mi A500 tenía problemas intermitentes, hasta que lo arranqué sin la ampliación de RAM del trapdoor. La solución fue cambiar los condensadores electrolíticos de la ampliación.


No, es un 1200 pelado.

Un saludo.

Re: Amiga 1200 black screen y sin actividad de disquetera

Publicado: 05 Abr 2019 20:00
por flopping
El ordenador al arrancar, hace un chequeo de los chips, si alguno falla, es probable que se quede con la pantalla negra, pero claro, la única forma de saber si es un chip, es ir cambiando uno por uno con otro ordenador que funcione, o en su defecto, ir comparando zonas en un ordenador bueno y en el tuyo, para ver si difiere en algo, quizá con un analizador lógico de esos que valen 10 euros, puedas ver el arranque de un equipo bueno y compararlo con el tuyo, ver si el micro tiene la misma actividad, si ciertas señales llegan a los mismos sitios y cosas así, sé que es mucho trabajo, pero sin más referencias no podemos adivinar por dónde está el fallo, más que midiendo un equipo bueno y comparándolo con el tuyo.

Re: Amiga 1200 black screen y sin actividad de disquetera

Publicado: 05 Abr 2019 20:39
por minter
flopping, el A1200 tiene casi todo soldado SMD, menos las ROMs. No se puede ir cambiando chips como si fuera un 500.
A parte de todos lps gusarapus que hayan devorado pistas y cosas de esas, comparto lo que me pasa a mí.
Tengo un 2000. Y siempre que lo enciendo, pantalla negra con la luz de power a medio gas. Como tú!
Entonces aprieto a ROM y vuelve a funcionar.
Mi 2000 escupe los chips del sitio. Saltan del zocalo ellos solos porque sí. La placa es una pandereta y los escupe a la minima vibracion.
Aprieto.... y va!
Y a veces no va a la primera.
Pero siempre consigo arrancarlo. :)

Re: Amiga 1200 black screen y sin actividad de disquetera

Publicado: 05 Abr 2019 23:23
por Hodor
Después de pensarlo un rato, tengo mis dudas sobre si el hecho de que el corto que lo resucitó se produjo en una de las ROMS puede ser en sí mismo una pista sobre el origen del problema. Me gustaría cambiar el condensador de desacoplo C6B y así ir descartando posibles causas. Por cierto, según el esquemático es de 0.22uF pero desconozco ciertos detalles: parece cerámico, por tanto sin polaridad, pero no sé su voltaje. ¿Alguien podría decirme más datos sobre él si es posible?:

Imagen

Igualmente resoldaré los zócalos de las ROMS que tampoco se pierde nada por hacerlo y volveré a comprobar pistas por si acaso se me hubiera pasado algo por alto.

Paciencia en todo caso -grin

Re: Amiga 1200 black screen y sin actividad de disquetera

Publicado: 06 Abr 2019 12:38
por minter
La tensión va a ser lo de menos. Tienes 5v ahí.
si localizo luego el part list del amiga, miro a ver si pone tensión, pero no es critico.
Es mas... Yo, que soy un chapuzas, pondía un condensador de lenteja ahí, sacado de cualquier otro lado. Creo que sería uno de lenteja con serigrafía 222. (confirmar)

Re: Amiga 1200 black screen y sin actividad de disquetera

Publicado: 06 Abr 2019 23:05
por Kyp
224 diría yo. Por voltaje no hay problema, esos condensadores suelen aguantar mucho más de 5V.

Re: Amiga 1200 black screen y sin actividad de disquetera

Publicado: 06 Abr 2019 23:32
por Hodor
minter escribió:La tensión va a ser lo de menos. Tienes 5v ahí.
si localizo luego el part list del amiga, miro a ver si pone tensión, pero no es critico.
Es mas... Yo, que soy un chapuzas, pondía un condensador de lenteja ahí, sacado de cualquier otro lado. Creo que sería uno de lenteja con serigrafía 222. (confirmar)


Kyp escribió:224 diría yo. Por voltaje no hay problema, esos condensadores suelen aguantar mucho más de 5V.


Gracias a ambos -thumbup

Se me ha ocurrido lo siguiente: con un multímetro decente que mida capacitancia, ¿podría detectar condensadores defectuosos en la placa de una forma más o menos fidedigna? Lo pregunto porque mi multímetro, si bien no es malo, aparte de ser analógico y de carecer de esa función concreta tiene ya unos cuantos años encima y llevo tiempo pensando en cambiarlo.

Por decente hablo de algo que cueste 60-70€ como mucho.