Salvad al soldado Kenitec (reviviendo un 286, con fotos)

Montserrat
Mensajes: 22
Registrado: 12 Ene 2018 14:28
Agradecido : 4 veces
Agradecimiento recibido: 6 veces

Salvad al soldado Kenitec (reviviendo un 286, con fotos)

Mensajepor Montserrat » 08 Feb 2019 18:08

Hola buenas! Pues vengo a compartir esta experiencia que he comenzado hoy, y es que he sacado de un almacen polvoriento y oscuro los restos mortales de este 286, sabia que me lo iba a comer y que no funcionaria, pero iguamente me lo lleve para intentar rescatarlo (es parte de la diversion).

Bueno seguramente acabare necesitando ayuda de una forma u otra asi que he decidido ir poniendo los avances aqui asi todos podemos salvar al soldado kenitec :D.

Os pongo en antecedentes:
- Procesador 286 a 16mhz
- Placa base suntac 286-12
- Memoria, desconocida, ya que tiene un monton de configuraciones posibles con los DIP, lo mas probable es que sean 2MB o 640kb.
- Disco duro de 20MB 5.25" ST225 (como mola...)
- Disquetera 1.2MB 5.25"
- Tarjeta controladora para 2 HDD Dy 2 FDD
- Targeta grafica Peaktron electronics (CGA creo)
- Tarjeta de red coaxial
- Cartucho de proteccion de software insertado en uno de los BUS ISA. (no se de que es, aunque sospecho que del SO Theos 32, ya recogi tambien algunos disquetes viejos de este sistema, aunque eran de 3,5")
- Pantalla 14hp33t 14" monocroma, 9 pines, seguramente fosforo blanco, aunque hay una posibilidad remota de que sea verde.

Imagen

Por supuesto el pc no parece funcionar, cuando me lo lleve de alli estaba oscuro y no vi el manchote de corrosion que habia en una esquina. Problems que me he encontrado:

- No hay beep code, silencio total.
- No hay imagen, aunque tambien podria ser que el monitor estuviera muerto.

Cosas que ya he hecho:

- Comprove la fuente: los railes de 5V -> dan 8V, los railes de 12V dan 19V, no estoy seguro de si esto es normal.
- El HDD arranca, la disquetera no en este pc, la he probado en mi pc de diario y si arranca, aunque no tengo disquetes de 5,25" para probarla.
- He retirado la pila antigua que esta totalmente agotada
- He reitrado el conector DIN del teclado ya que estaba invadido por la corrosion.
- He limpiado en la medida de lo posible la corrosion de la placa y he comprobado las pistas mas atacadas, dando continuidad estas (menos mal).
- Substitui las pegatinas de las roms de las bios (lleva dos bios conmutables) por que se cayeron en cuanto abri la caja, para evitar que se borren por la luz del sol.

Imagen
Imagen
Imagen
Imagen

Siguientes pasos:

- Comprar una bateria y un conector din nuevos
- Hacer comprobaciones de todos los componentes cercanos a la corrosion.
- Comprar una tarjeta VGA para poder descartar el monitor llegado el momento
- Comprar algun disquete de 5,25" para poder probar la disquetera.

Os dejo con algunas fotos para chafardear...son con el movil, pero si es necesario ya sacare la reflex para los detalles:

Enlace a galeria de imgur: https://imgur.com/a/ecfzVuc

Avatar de Usuario
Jinks
Mensajes: 1521
Registrado: 09 Oct 2013 16:47
Agradecido : 110 veces
Agradecimiento recibido: 150 veces
Contactar:

Re: Salvad al soldado Kenitec (reviviendo un 286, con fotos)

Mensajepor Jinks » 08 Feb 2019 19:12

Cuando mides la salida de una fuente sin tener nada conectado a ella, salen unos voltajes raros, pero 8 y 19 me parecen muy altos para 5 y 12...
Si en algún momento ha llegado eso a la placa, fijo que se ha quemado más de un chip.

Montserrat
Mensajes: 22
Registrado: 12 Ene 2018 14:28
Agradecido : 4 veces
Agradecimiento recibido: 6 veces

Re: Salvad al soldado Kenitec (reviviendo un 286, con fotos)

Mensajepor Montserrat » 08 Feb 2019 20:18

Bueno empezare por medir todos los componentes que pueda si veo que empeiza a haber cosas fritas ya vere que hago. Mañana que tendre luz natural vere.

muon
Mensajes: 210
Registrado: 03 Jul 2017 11:46
Ubicación: Madrid
Agradecido : 12 veces
Agradecimiento recibido: 41 veces

Re: Salvad al soldado Kenitec (reviviendo un 286, con fotos)

Mensajepor muon » 09 Feb 2019 08:32

Conectores:
https://es.aliexpress.com/item/50-unids ... 63c0oXHYbc


Baterias:
https://es.aliexpress.com/item/10-Piece ... 63c0fTUfqA


Son los componentes que he utilizado de momento con exito

Avatar de Usuario
elfoscuro
Mensajes: 1386
Registrado: 01 Jun 2012 20:46
Agradecido : 1 vez
Agradecimiento recibido: 60 veces
Contactar:

Re: Salvad al soldado Kenitec (reviviendo un 286, con fotos)

Mensajepor elfoscuro » 09 Feb 2019 10:41

Abre la fuente, y mira si ves cosas raras... Está claro que hablamos de un 286, pero habitualmente las fuentes que he probado en vacío no se van mucho de los 5 y 12V. Esa se va una barbaridad. No te extrañe abrir la fuente y ver ácido por todas partes...

Montserrat
Mensajes: 22
Registrado: 12 Ene 2018 14:28
Agradecido : 4 veces
Agradecimiento recibido: 6 veces

Re: Salvad al soldado Kenitec (reviviendo un 286, con fotos)

Mensajepor Montserrat » 09 Feb 2019 19:02

Hola, he podido encontrar un manual en pdf de la placa, bueno no exactamente la misma, pero 99% igual, de modo que he podido corregir los jumpers, y los switches, averiguar la configuracion de memoria, y aclararme con el pinaje del panel frontal.

Aqui el manual: https://www.docdroid.net/dSi0OIR/magitronic-b236-80286-suntac-manual.pdf

- La confguracion de memoria ahora es 640kb + 1408Kb (2Mb) (sin EMS), modo zero wait state.
- He corregido un switch que le indicaba a la placa que debia dar señal para monitor a color cuando mi monitor es monocromo.

Sigue sin haber ninguna imagen o sonido, aunque he comprobado que la salida MDF?/EGA/CGA (aun no lo se) si da "señal". Sigo pendiente de probar con una VGA cuando consiga una.

La fuente la abrire mañana por la mañana que tendre luz natural.

En cuanto al conector del teclado lo he testeado y parece funcionar perfectamente, asi que le estoy dando un tratamiento anticorrosion y lo rescato si puedo. Aqui tomandese un chupito de vinagre...

Imagen

La bateria no me queda otra que comprar una gracias por el enlace!!!

Avatar de Usuario
Drtad
Mensajes: 724
Registrado: 19 Ago 2017 11:21
Agradecido : 71 veces
Agradecimiento recibido: 131 veces

Re: Salvad al soldado Kenitec (reviviendo un 286, con fotos)

Mensajepor Drtad » 09 Feb 2019 20:27

Para la batería aprovecha y pon un porta baterías o portapilas
A.N.O.N.I.M.O.X.: Artificial Networked Organism Normally for Intensive Mathematics and Online Xenocide

Montserrat
Mensajes: 22
Registrado: 12 Ene 2018 14:28
Agradecido : 4 veces
Agradecimiento recibido: 6 veces

Re: Salvad al soldado Kenitec (reviviendo un 286, con fotos)

Mensajepor Montserrat » 10 Feb 2019 12:02

Bueno he añadido nuevas fotos a la galeria https://imgur.com/gallery/ecfzVuc

Abriendo la fuente he visto algo que ha filtrado, pero no estoy muy seguro, si ha salido de los condensadores, o es algo usado para sellar...

https://imgur.com/WqKF56o

En todo caso los valores de voltaje con toda seguridad han frito la placa, la única esperanza es que llevara algún tipo de circuito de protección que haya saltado, voy a intentar identificarlo, aunque la verdad no tengo ni idea de esto. Dejo una foto de la zona cercana al conector de energia por si alguien me puede ayudar:

https://imgur.com/a/ecfzVuc
https://imgur.com/Q3u65vo

Avatar de Usuario
Jinks
Mensajes: 1521
Registrado: 09 Oct 2013 16:47
Agradecido : 110 veces
Agradecimiento recibido: 150 veces
Contactar:

Re: Salvad al soldado Kenitec (reviviendo un 286, con fotos)

Mensajepor Jinks » 10 Feb 2019 14:15

Montserrat escribió:Abriendo la fuente he visto algo que ha filtrado, pero no estoy muy seguro, si ha salido de los condensadores, o es algo usado para sellar...

No sé exactamente qué es eso, pero no parece que venga de un "escape", parece puesto ahí "de serie". Igual para que no se mueva el núcleo de ferrita, aunque si es eso, se han pasado un poco.

Avatar de Usuario
minter
Mensajes: 2342
Registrado: 22 Jul 2014 18:51
Agradecido : 2101 veces
Agradecimiento recibido: 926 veces

Re: Salvad al soldado Kenitec (reviviendo un 286, con fotos)

Mensajepor minter » 10 Feb 2019 14:40

Uy! Lo que acabo de ver!
Baba de alien?
Hace años se echaba un pegamento para sujetar componentes, que después de los años, al degradarse, corroía pistas y se volvía conductor.
Llamado en los foros de Creative como Baba de Alien. Ha destrozado mogollón de altavoces y amplis de ordenador.
Por el color de las fotos, se me parece pero no puedo afirmarlo.
Haz una prueba: sobre el propio pegamento, con el ohmetro, mide continuidad. Si el pegamento conduce, puede que esté haciendo alguna pifia en la fuente.
Y debajo del pegamento, puede estar haciendo corto entre el condensador y las pistas.
Si está casi cristalizado el pegamento, tiene bastantes papeletas de ser Baba conductiva.

Ya nos contarás la prueba.

No me lo invento, me ha pasado con un ampli Creative de ordenador. De esos gordos con subbuffer.

Montserrat
Mensajes: 22
Registrado: 12 Ene 2018 14:28
Agradecido : 4 veces
Agradecimiento recibido: 6 veces

Re: Salvad al soldado Kenitec (reviviendo un 286, con fotos)

Mensajepor Montserrat » 10 Feb 2019 15:44

Actualizo:
Otra persona ajena al foro me ha confirmado que esa "baba" es solo un sellante, pero lo mejor es que es mi MULTIMETRO el que esta mal, ha muerto y me da valores mucho mas altos, lo he probado con la fuente de mi PC y me da exactamente los mismos valores 8v y 19v respectivamente, ademas una pila AA de 1,2V me da 2,1V....asi que toca multimetro nuevo. Mañana mas...

Montserrat
Mensajes: 22
Registrado: 12 Ene 2018 14:28
Agradecido : 4 veces
Agradecimiento recibido: 6 veces

Re: Salvad al soldado Kenitec (reviviendo un 286, con fotos)

Mensajepor Montserrat » 11 Feb 2019 16:10

Bueno ya tengo multimetro nuevo y he comprado una tarjeta de diagnostico...

Efectivamente la fuente esta correcta, era mi multimetro haaciendome la jugarreta... ya obtengo los 5 y 12 voltios respectivamente.

Tambien he usado la tarjeta de diagnostico y he obtenido dos codigos de error dependiendo de si lo pongo en los slots 1-6 -> error 01 (BAD CPU) o en los 7-8 -> error A1 (keylock check).

He comprobado lo del keylock que supongo se refiere a la llave fisica que tiene el pc, y esta abierta.

Y en cuanto a la CPU, la he sacado y vuelto a poner del socket, pero no ha habido suerte.

No se si esto opdria deberse a una bios corrupta( ya que recibio luz solar durante almenos un dia), o que realmente la cpu esta mal.

Opiniones?

Montserrat
Mensajes: 22
Registrado: 12 Ene 2018 14:28
Agradecido : 4 veces
Agradecimiento recibido: 6 veces

Re: Salvad al soldado Kenitec (reviviendo un 286, con fotos)

Mensajepor Montserrat » 05 Mar 2019 19:52

Perdon por no actualizar, la reparacion continuo en este otro foro (en ingles) ya que me estan ayudando mucho. Dejo el enlace para futuras referencias por si alguien lo necesita, tiene bastante tela, pero se aprenden muchas cosas (aun esta en proceso):

https://www.vogons.org/viewtopic.php?f=46&t=65214

Avatar de Usuario
Jinks
Mensajes: 1521
Registrado: 09 Oct 2013 16:47
Agradecido : 110 veces
Agradecimiento recibido: 150 veces
Contactar:

Re: Salvad al soldado Kenitec (reviviendo un 286, con fotos)

Mensajepor Jinks » 05 Mar 2019 22:03

¿Que la tarjeta de diagnóstico te da distintos errores dependiendo del slot en el que la insertas?
Eso sí que es raro. El PC simplemente va enviando números durante cada fase del POST al puerto 80h, y la tarjeta de diagnóstico simplemente se conecta al puerto 80h y enseña lo que recibe del PC.

No sé qué conclusiones se pueden sacar de ahí, pero si el PC no se comporta igual dependiendo de que la tarjeta esté insertada en un slot o en otro, es que pasa algo muy raro.

De todas formas, que la tarjeta llegue a mostrar algún código POST ya es buen síntoma. Además de los códigos POST, incluso las más básicas tienen la opción de mostrar de alguna manera la velocidad del bus. Mira a ver qué te da en los distintos slots, debería indicar unos 8 MHz en todos.


Volver a “PC & Compatibles X86”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado