Reparando un IBM 5160 XT

Avatar de Usuario
Jinks
Mensajes: 1272
Registrado: 09 Oct 2013 16:47
Agradecido : 56 veces
Agradecimiento recibido: 110 veces
Contactar:

Re: Reparando un IBM 5160 XT

Mensajepor Jinks » 09 Jul 2018 14:46

Último mensaje de la página anterior:

Ah, entonces esas pantallas las saca la propia ROM sin que llegue a arrancar... Bueno, ahora que se ve bien parece que el problema no tiene nada que ver con la tarjeta de vídeo, eran las líneas del bus de datos.
Ahora se queja del temporizador, DMA y memoria, probablemente esté todo relacionado, igual si solucionas lo de la memoria se te arregla todo lo demás.

jltursan
Mensajes: 2197
Registrado: 20 Sep 2011 13:59
Agradecido : 101 veces
Agradecimiento recibido: 270 veces

Re: Reparando un IBM 5160 XT

Mensajepor jltursan » 09 Jul 2018 17:55

Se va progresando, ¡siempre son los buffers! -grin

Como ya te dije, no te fíes de los integrados de memoria que intercambiaste de banco. Parte de unos 100% comprobados.

Avatar de Usuario
Drtad
Mensajes: 518
Registrado: 19 Ago 2017 11:21
Agradecido : 40 veces
Agradecimiento recibido: 92 veces

Re: Reparando un IBM 5160 XT

Mensajepor Drtad » 09 Jul 2018 23:02

Suena a memoria defectuosa o no compatible con el pc
A.N.O.N.I.M.O.X.: Artificial Networked Organism Normally for Intensive Mathematics and Online Xenocide

Avatar de Usuario
mj8bit
Mensajes: 200
Registrado: 07 Jul 2011 12:12
Ubicación: Ecija
Agradecido : 20 veces
Agradecimiento recibido: 11 veces

Re: Reparando un IBM 5160 XT

Mensajepor mj8bit » 10 Jul 2018 09:56

Ayer cambié las memorias del banco 0 por otras que puedo confirmar que también funcionan de un IBM portable y tengo el mismo resultado. Seguiré centrándome en los integrados.

Avatar de Usuario
mj8bit
Mensajes: 200
Registrado: 07 Jul 2011 12:12
Ubicación: Ecija
Agradecido : 20 veces
Agradecimiento recibido: 11 veces

Re: Reparando un IBM 5160 XT

Mensajepor mj8bit » 28 Jul 2018 09:45

Revisando los chip implicados en los fallos hay un denominador común que sigue siendo el bus D0-D7, así que me volví a centrar en los chips anteriormente cambiados. Entonces me di cuenta que el U9 (LS245) no cambiaba de estado nunca por la señal proveniente del chip U24 (LS00) siempre en HI. En efecto, le hice las pruebas con la sonda lógica y aunque en una parte la señales de entrada cambiaban la salida al chip U9 siempre estaba HI.
Al sustituir el chip U24 el resultado fué:

IMG_0495 (1).jpg
IMG_0495 (1).jpg (138.69 KiB) Visto 104 veces


Placa reparada!!!!

Avatar de Usuario
minter
Mensajes: 1815
Registrado: 22 Jul 2014 18:51
Agradecido : 1180 veces
Agradecimiento recibido: 496 veces

Re: Reparando un IBM 5160 XT

Mensajepor minter » 28 Jul 2018 10:45

Eso si que es tocar las narices. Cambiar un integrado y poner otro con fallos es una gran P.
Diste con ello, ahora yes un gusarapin de nivel PRO. -507


Volver a “PC & Compatibles X86”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado